1

I have installed emacs on a new mac machine and the spell checker (which used to work on an older machine) has stopped working. Here is the details:

OS: MacOS Mojave, V. 10.14.2

Emacs: GNU Emacs 26.1 (build 1, x86_64-apple-darwin18.2.0, Carbon Version 158 Appkit 1671.1) of 2018-11-17

helm-flyspell set up:

(use-package helm-flyspell :ensure t)

(setq ispell-program-name "/opt/local/bin/hunspell")

(global-set-key (kbd "< f8 >") 'helm-flyspell-correct)

hunspell: it is installed via macports together with a dictionary

Backtrace output:

Debugger entered--Lisp error: (wrong-type-argument stringp nil)

string-match("," nil 0)

split-string(nil "," t)

ispell-parse-hunspell-affix-file(nil)

ispell-hunspell-fill-dictionary-entry(nil)

ispell-start-process()

ispell-init-process()

ispell-buffer-local-words()

ispell-accept-buffer-local-defs()

flyspell-accept-buffer-local-defs()

helm-flyspell-correct()

funcall-interactively(helm-flyspell-correct)

call-interactively(helm-flyspell-correct nil nil)

command-execute(helm-flyspell-correct)

Does anyone know what is going wrong? I have limited Elisp knowledge. It appears that the word I want to check its spelling by placing my cursor around it and pressing F8 key is not parsed and passed to the spell checker properly. I should also add that I get error when I want to enable flyspell-mode. The error message in the echo area is the same (stringp nill) but I cannot get the backtrace output on that.

Many thanks,

PS: I have reinstalled helm-flyspell without any effect.

migrated from superuser.com Jan 8 at 22:09

This question came from our site for computer enthusiasts and power users.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy