0

I want to set emacs as the default editor for crontab

me@me:~$ cat .selected_editor 
# Generated by /usr/bin/select-editor
SELECTED_EDITOR="/usr/bin/emacs -nw"

but find this solution too heavy for some easy task, so I re-configure it as

me@me:~$ cat .selected_editor 
# Generated by /usr/bin/select-editor
SELECTED_EDITOR="/usr/bin/emacs -Q"

emacs was opened but in a GUI mode

How could I open it in terminal in a basic mode

3

Simply combine the arguments you've already used:

SELECTED_EDITOR="/usr/bin/emacs -Q -nw"
  • amazing, why emacs -Wnw not working. – Alice Jan 13 '19 at 11:18
  • -W is not a valid option. See man emacs for a list. – Heikki Jan 13 '19 at 16:49
  • Or emacs --help – phils Jan 13 '19 at 19:44
  • @Alice, if you read somewhere that -Wnw would be valid, perhaps you could try to correct that source. – phils Jan 13 '19 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.