1

When using magit-commit-create, internally it runs something like...

  • git commit . instead of...
  • git commit -a

Is there a way to make magit use -a / --all by default instead?


Note: this is an important difference because this causes sub-modules to be committed each time, which I don't want to do (since the sub-modules have master checked out and I don't want to be changing the submodule sha1 for every commit).

1

This can be done by setting magit-commit-arguments, for example:

(setq magit-commit-arguments '("--all"))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.