0

I've built GNU Emacs 27.0.50 from source in Ubuntu 18.10. Then started the daemon as a systemd unit:

[Unit]
Description=Emacs text editor
Documentation=info:emacs man:emacs(1) https://gnu.org/software/emacs/

[Service]
Type=notify
ExecStart=/home/marcanuy/local/bin/emacs --fg-daemon
ExecStop=/home/marcanuy/local/bin/emacsclient --eval "(kill-emacs)"
Environment=SSH_AUTH_SOCK=%t/keyring/ssh
Restart=on-failure

[Install]
WantedBy=default.target

When I start emacsclient running emacsclient -c it quits after a while without any errors.

Even running it with gdb doesn't shows anything:

(gdb) exec-file emacsclient
(gdb) set args -c
(gdb) run
Starting program: /home/marcanuy/local/bin/emacsclient -c
Waiting for Emacs...
[Inferior 1 (process 2858) exited normally]
(gdb) bt
No stack.

It happened configuring it with and without x-lucid:

./configure --prefix=$HOME/local

and

./configure --prefix=$HOME/local --with-x-toolkit=lucid

both have the same problem.

Also, the daemon is running without problems:

$ systemctl --user status emacs.service 
● emacs.service - Emacs text editor
   Loaded: loaded (/home/marcanuy/.config/systemd/user/emacs.service; enabled; vendor preset: enabled)
   Active: activating (start) since Tue 2019-01-15 06:13:47 -03; 1min 16s ago
     Docs: info:emacs
           man:emacs(1)
           https://gnu.org/software/emacs/
 Main PID: 3138 (emacs)
   CGroup: /user.slice/user-1000.slice/user@1000.service/emacs.service
           └─3138 /home/marcanuy/local/bin/emacs --fg-daemon

ene 15 06:13:47 scarone systemd[1383]: Stopped Emacs text editor.
ene 15 06:13:47 scarone systemd[1383]: Starting Emacs text editor...
ene 15 06:13:54 scarone emacs[3138]: Loading /home/marcanuy/.emacs.d/helm-adaptive-history...
ene 15 06:13:54 scarone emacs[3138]: Loading /home/marcanuy/.emacs.d/helm-adaptive-history...done
ene 15 06:13:57 scarone emacs[3138]: [yas] Prepared just-in-time loading of snippets (but no snippets found).
ene 15 06:13:58 scarone emacs[3138]: [yas] Prepared just-in-time loading of snippets (but no snippets found).
ene 15 06:13:59 scarone emacs[3138]: Turning on magit-auto-revert-mode...
ene 15 06:13:59 scarone emacs[3138]: Turning on magit-auto-revert-mode...done
ene 15 06:13:59 scarone emacs[3138]: Starting Emacs daemon.

Any idea?

  • You're running an unstable release. Does the same thing happen with the latest stable version? – phils Jan 15 at 9:32
  • @phils just tested and works fine in the latest stable release 26.1.91. – marcanuy Jan 15 at 20:45
  • FYI strictly speaking 26.1.91 is also not a stable release (it's a pre-test for 26.2), although it ought to be very stable in practice, so I wouldn't drop back to 26.1 (which is the current stable release) unless you're having further problems. Versions ending in .9x are pre-test releases (more or less "release candidates"). Versions ending in .50 are unstable. Please use M-x report-emacs-bug (ideally from within the 27.0.50 build, if you still have it) to report the original problem. – phils Jan 15 at 23:00
  • @phils thanks for clarifying that, I got confused because it was the latest release available at the GitHub mirror repo, will try to report the bug when trying 27 again. – marcanuy Jan 16 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.