3

I use mu4e. When I reply-all to an email, my own email appears in CC. I have these lines in my configuration:

(setq mu4e-compose-dont-reply-to-self t)
(setq
 message-send-mail-function   'smtpmail-send-it
 user-mail-address "email@domain.com"
 ...
)

I don't have multiple accounts as in this Github issue. The value of the variable mu4e-user-mail-address-list is my username@hostname.domain.tld, where username is my login name and hostname.domain.tld is the hostname of the computer.

When I click Customize this variable, I see that it was changed, but not by me:

INS DEL Address: username@hostname.domain.tld
INS
 State : CHANGED outside Customize.

How can I avoid my email when replying to all?

1

Old question, but since it is the first thing that pops up in google (at least for me), I guess it is worth updating.

The answer provided by @miguelmorin no longer works, see the manual for Writing messages, C.4.9:

You need list your personal addresses by passing one or more --my-address=... to mu init. Note that the mu4e-user-mail-address-list which was used in older mu4e versions is no longer used. Also see the entries for version 1.4 in NEWS.org (N) in the main-menu.

You now have to use mu to register your email address:

mu init --maildir=/path/to/mail/folder --my-address=example@example.com

After this, you can control the inclusion of your email address in CC while a reply-to-all configuring the mu4e-compose-keep-self-cc in ~/.emacs (it defaults to nil).

If you have multiple email addresses, you need to include that many --my-address=... parameters, per the documentation:

mu init --maildir=~/Maildir --my-address=jim@example.com --my-address=bob@example.com
| improve this answer | |
1

Update: This answer is for mu4e before version 1.4. See above for the solution with the more recent version.

It seems that mu4e does not pick up the email address from the sendmail settings. The variable mu4e-user-mail-address-list was changed outside of the initialisation file and one can override it with:

(setq mu4e-user-mail-address-list (quote ("email@domain.com")))

Evaluate the region or reload the file, and now mu4e no longer includes the email in reply-all. And when you reply to an email sent from one person to you, it does not ask you whether to reply all or just to the sender.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.