0

I've been using the following setup Gnus SMTP

;;; SMTP
(defun email-settings ()
  (interactive)
  (setq message-send-mail-function 'smtpmail-send-it
        starttls-gnutls-program "gnutls-cli"
        starttls-use-gnutls t
        smtpmail-stream-type 'starttls
        smtpmail-default-smtp-server "smtp.mail.me.com"
        smtpmail-smtp-server "smtp.mail.me.com"
        smtpmail-smtp-service 587
        smtpmail-smtp-user "[email protected]"
        smtpmail-debug-info t
        smtpmail-debug-verb t))

for years to send the email via Gnus using gnutls-cli. This setup stopped working recently on the starttls call:

Opening STARTTLS connection to ‘smtp.mail.me.com:587’...

When debugging the STARTTLS with gnutls-cli I am seeing this:

(~)[498]$ gnutls-cli --verbose --starttls --tofu -p 587 smtp.mail.me.com
|<1>| There was a non-CA certificate in the trusted list: O=Entrust.net,OU=www.entrust.net/CPS_2048 incorp. by ref. (limits liab.),OU=(c) 1999 Entrust.net Limited,CN=Entrust.net Certification Authority (2048).
Processed 175 CA certificate(s).
Resolving 'smtp.mail.me.com:587'...
Connecting to '17.56.136.170:587'...

- Simple Client Mode:

- Received[47]: 220 mr85p00im-zteg06012001.me.com 3.3.1 v.666`

and it never completes. Does somebody know what's changed and what's wrong and how to fix that?

7
  • Is Emacs' smtpmail broken? #smtpmail
    – The Dude
    Jan 19, 2019 at 18:16
  • Have you tried using 'gnutls-cli --insecure' to skip the certificate verification? (not recommended for production use). Longer term you might want to try using Emacs' builtin TLS support.
    – rpluim
    Jan 21, 2019 at 9:20
  • Unfortunately, the --insecure parameter doesn't solve my issue.
    – The Dude
    Feb 4, 2019 at 10:55
  • After switching to the internal TLS support I am getting this log sequence: Sending via mail... Opening TLS connection to ‘smtp.mail.me.com’... Opening TLS connection with ‘gnutls-cli -p 587 smtp.mail.me.com’...failed Opening TLS connection with ‘gnutls-cli -p 587 smtp.mail.me.com --protocols ssl3’...failed Opening TLS connection with ‘openssl s_client -CAfile /etc/ssl/cert.pem -connect smtp.mail.me.com:587 -no_ssl2 -ign_eof’...done Opening TLS connection to ‘smtp.mail.me.com’...done network-stream-command: Process smtpmail<2> not running
    – The Dude
    Feb 4, 2019 at 10:56
  • I don't think you're using the builtin support, those messages come from tls.el. Have you unset starttls-gnutls-program and starttls-use-gnutls?
    – rpluim
    Feb 4, 2019 at 12:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.