1

I have been attempting to disable a prompt by auctex when pressing C-c C-c to view the document for close to the entire day. As I am a noob to emacs, I attempted to simply modify the auctex configuration used here. can anyone give me advice what is causing the view prompt?

In essence, I want to compile the file without any request to view the results.

my block is as such so far:

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; latex
; based on:
; https://nasseralkmim.github.io/notes/2016/08/21/my-latex-environment/

(use-package tex-site
  :ensure auctex
  :mode ("\\.tex\\'" . LaTeX-mode)
  :config
  (setq TeX-auto-save t)
  (setq TeX-parse-self t)
  (add-hook 'LaTeX-mode-hook
            (lambda ()
            (setq TeX-PDF-mode FALSE)
              (rainbow-delimiters-mode)
              (company-mode)
              (smartparens-mode)
              (turn-on-reftex)
              (setq reftex-plug-into-AUCTeX t)
              (reftex-isearch-minor-mode)
              (setq TeX-source-correlate-method 'synctex)
              (setq TeX-source-correlate-start-server t)))
)

;; reftex
(use-package reftex
  :ensure t
  :defer t
  :config
  (setq reftex-cite-prompt-optional-args t)); Prompt for empty optional arguments in cite

To clarify what I have attempted, I attempted to apply all answers related to "How to disable doc-view in AUCTex". I have also attempted to modify each line of the block individually, but I cannot determine what is causing the view prompt.

p.s., I may have applied the answer described here wrong. After the hook, I had (TeX-command-Show LaTeX). is this wrong?

closed as off-topic by Tyler, Drew, Stefan, DoMiNeLa10 Feb 21 at 17:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about emacs, within the scope defined in the help center." – Tyler, Drew, Stefan, DoMiNeLa10
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What do you want to happen when you press C-c C-c? Do you want it to only compile your document, never to display it? Or do you want it to display it automatically without prompting you? I'm not sure what you're trying to do – Tyler Jan 21 at 3:50
  • @Tyler to compile without displaying. Weirdly enough, with the same init file on my work computer instead of my home computer, the work computer doesn't ask for a view prompt. Might be something else outside of emacs that's causing this. – agenttiny Jan 21 at 5:31
  • I don't know what has changed, but the prompt has now completely disappeared. I think it was restarting the computer, not emacs, that somehow made it work as i expected... – agenttiny Jan 21 at 16:32
0

This is the answer to my own question/problem that probably won't help anyone: I believe that restarting the PC, not emacs, somehow solved the problem. The init code above just suddenly started working as I expected.

Not the answer you're looking for? Browse other questions tagged or ask your own question.