0

I just installed Emacs26 on my Windows 7 64-bit computer and whenever I try setting a mark ctrl + <space>, it toggles the Windows language settings instead. M-x set-mark-command works as expected though.

  • 1
    Probably a shortcut that Windows is intercepting before Emacs gets it – imabug Jan 25 at 10:44
1

There is something happening between when you press C-<SPC> and when that signal is sent to Emacs. The path from key press to action on the screen is surprisingly complex.

To troubleshoot it, first make sure that any obvious stuff is turned off. Disable any application like AutoHotKey.

From there, things are trickier to handle. However, it seems that C-<SPC> is a common problem with Chinese keyboards. Might you be using one?

If so, this super user post is relevant. The relevant content is from user Kache and is given below (for posterity). If it helps you, make sure you jump over to the original post to give the author credit. I'm just a middle man.

Procedure

  1. Go to Start > Type in regedit and start it
  2. Navigate to HKEY_CURRENT_USER/Control Panel/Input Method/Hot Keys
  3. Select the key named: * 00000070 for the Chinese (Traditional) IME - Ime/NonIme Toggle hotkey * 00000010 for the Chinese (Simplified) IME - Ime/NonIme Toggle hotkey
  4. In the right sub-window, there are three subkeys. * Key Modifiers designate Alt/Ctrl/Shift/etc and is set to Ctrl (02c00000). * Virtual Key designates the finishing key and is set to Space (20000000).
  5. Change the first byte in Key Modifiers from 02 to 00
  6. Change the first byte in Virtual Key from 20 to FF
  7. Log off and log back on. I don't think it's necessary to restart.
  8. Do not change the Hot keys for input languages in Control Panel, unless you want to do this all over again.

Notes: Symptoms

Each registry key (thing that looks like a folder) is for each specific hotkey setting that you would normally find in `Control Panel

Region and Language > Keyboards and Languages > Change keyboards... > Advanced Key Settings > Hot keys for input languages`. The recurring bug is the hotkey being automatically reset to Ctrl+space even if changed via the GUI.

This is for Windows 7 64-bit, though from my research, it looks like it may work for XP and Vista as well.

Sources:

Traditional Chinese Pocket IME Hot Key Registry Settings

Simplified Chinese MSPY 3.0 IME Hot Key Registry Settings

1: http://msdn.microsoft.com/en-us/library/ms904366.aspx
2: http://msdn.microsoft.com/en-us/library/ms904626.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.