0

I'm on macOS 10.14.2 and Emacs 26.1 with the latest version of mactex (via brew cask install mactex). However, I cannot get my PDF to render with Org-export latex. I am looking at the *Org Export Process* and I only get a message printed saying Processing LaTeX file my_file_name.tex... and never ends compilation. I have tried re-installing mactex and I still have the same issue.

I would like to know if this is a common problem and where I can start debugging.

EDIT: The issue is when I try to export to LaTeX and then to PDF. I can export directly to latex but not to pdf.

  • weird. Some more context: I am compiling lots of svg images to the pdf. I added one by one and after the 3rd compilation emacs gets stuck. Im guessing rendering SVG is not a solved problem in emacs? – avocadoras Feb 4 at 17:53
  • The standard way to debug this is to try manually building the pdf at the command line, e.g. with pdflatex. It sounds like the issue is not in Emacs, but in the document. – John Kitchin Feb 4 at 18:19
  • I think the issue is the way I try to manipulate the dimensions for my SVG images. It does not work the same as a normal PNG images do work. I shall read more into the SVG package to figure out the origin of the issue. – avocadoras Feb 4 at 19:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.