0

Following example.org is expected to be exported in landscape though the generated pdf remains in portrait. What should I change?

** A3 PDF Landscape
   #+LATEX_HEADER: \usepackage[a3paper]{geometry}
   #+LATEX_HEADER: \usepackage[lscape]{geometry}
   #+ATTR_LATEX: :placement [H] :landscape
*** Flowchart landscape
    #+BEGIN_SRC mermaid :file myPicture1121.png
 graph LR
     john-->|calls|mary
    #+END_SRC
 #+RESULTS:
 [[file:myPicture1121.png]]

screenshot

1

Your LaTeX header is incorrect. You need to put all options for a package on one line, and the landscape option is landscape not lscape. It should read

#+LATEX_HEADER: \usepackage[a3paper,landscape]{geometry}

Your issue is thus entirely unrelated to Emacs and org mode.

| improve this answer | |
  • The above solution does not work for me. But this one works: emacs.stackexchange.com/questions/36802/… – Yu Shen Aug 7 '19 at 23:46
  • any other latex commands that make a document landscape should work as well, like the #+LATEX_CLASS_OPTIONS: [landscape] you linked. Not sure why the geometry package doesn't work for you, though. – Lorenz Aug 8 '19 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.