1

I try to customize the scrolling experience within Emacs and for that rebound M-n and M-p to a new functionality, namely

(global-set-key "\M-n" "\C-u20\C-v")
(global-set-key "\M-p" "\C-u20\M-v")

and while it works for M-n, M-p does not work. If I reassign the function to e.g. M-o it also works as expected. Only M-p is refusing to work although there is no functionality overwriting it later in my config file.

Can anyone help please?

running yields for M-n

M-n runs the command "20" (found in global-map), which is a keyboard macro. It is bound to M-n. Macro: C-u 20 C-v Keyboard macro.

if I try the same for M-p there is no reaction i.e. any diagnosis, just nothing happens. I tried the same in emacs -q with the same result. But C-p and the like work oO

closed as off-topic by Gilles Feb 20 at 17:57

  • This question does not appear to be about emacs, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It works as expected for me. After you make the bindings, what does C-h k M-p report? – Tyler Feb 20 at 14:43
  • That's strange. What happens when you call C-h k M-p when you start Emacs (i.e., before you try your new keybindings)? – Tyler Feb 20 at 15:46
  • 1
    1st: Can you reproduce the effect with emacs -Q? 2nd: M-p could be captured by a keymap of the operating system. (e.g., xmodmap). – Tobias Feb 20 at 16:14
  • 1
    I found it. Was overwritten in my awersome wm config file. thank you for your help! – Carsten D Feb 20 at 17:30
  • 1
    I'm closing this question because it was due to a problem entirely outside Emacs, and once this problem solved, no question about Emacs remains. – Gilles Feb 20 at 17:57