I'm following this tutorial:


* Tasks
** DONE start a new org file for tutorial
C-c C-t

modifies the second to line

** DONE start a new org file for tutorial

but is not followed by the expected

CLOSED <timestamp>

What to do?enter image description here


here's how .emacs.d/init.el is setup:

(require 'package)
(add-to-list 'package-archives '("org" . "https://orgmode.org/elpa/") t)
(require 'org)
(define-key global-map "\C-cl" 'org-store-link)
(define-key global-map "\C-ca" 'org-agenda)
(setq org-log-done t)

Try (setq org-log-done 'time).

  • In place or following (setq org-log-done t)? I tried both and it doesn't generate a timestamp. Also, C-x C-s does not save the task. – Erwann Feb 21 '19 at 4:33
  • I assumed that org-log-done would be nil (default), so it's not the point. Anyway, my emacs -Q with your init setup works as expected... – lurdan Feb 21 '19 at 7:57
  • I tried again and it worked with your solution. – Erwann Feb 27 '19 at 23:14
  • Subsidiary question: how to do I close without a timestamp with the new setup? – Erwann Mar 4 '19 at 17:55
  • Without setting org-log-done, timestamp will not be created when closing. It's default behavior. To ensure, you may explicitly set (setq org-log-done nil). – lurdan Mar 6 '19 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.