1

When reading manuals in *info* mode, I found rivers somewhat distracting. For example, the left image is what I see on the screen, whereas the right one have some rivers annotated out. (see also Tex.SE, and DSP.SE)

enter image description here

Is there anyway to avoid them? I have did a lot of searching, but haven't found a relevant package yet. The Emacs community doesn't seem to care too much about this issue...

  • When you come across a paragraph that bothers you this way, you can try this: C-x C-q then M-q. (Don't try to save your changes.) For the paragraph you show that works for me, apparently because it was not filled with a larger fill-column than what I use by default (70). IOW, you can refill the text, trying a different fill-column. The result might just result in different rivers, however. As @Stefan has said, Emacs development does not deal with this level of typography for online viewing - for one thing for lack of volunteers. On the other hand, try hardcopy versions of the manuals. – Drew Feb 24 at 23:03
2

I think this is basically a matter of reading text with fixed-width fonts, yes?

I suspect your best option is to enable M-x variable-pitch-mode for info buffers:

(add-hook 'Info-mode-hook 'variable-pitch-mode)

Note that you'll end up with a greater variability in visual line widths than before, as the manual text is filled / hard-wrapped (and I don't believe there's enough information to safely re-wrap them at render time, so I'm pretty sure that's a trade-off you'll be stuck with).

Otherwise (or in addition): try different fonts and see if you can find one which distracts you less than your current font.

  • Maybe? I am running Emacs within a terminal, so variable-pitch-mode doesn't seem to make any difference. I'll install the native version of Emacs later and try again. – nalzok Feb 24 at 4:14
  • In a terminal Emacs has no control over the font which is being used -- it's the terminal that determines the font, not Emacs. You could tell your terminal emulator to use a variable-width font, but then all Emacs buffers will use that, so I wouldn't recommend doing that unless this issue is a major problem for you. Otherwise I think your options are (a) find a fixed-width font which you like better (which I think is unlikely to make a big difference); (b) use GUI Emacs; or (c) forget about it. – phils Feb 24 at 5:24
1

I'm not sure if the Emacs community cares or not, but I can assure you that the manpower needed to fix this is definitely missing. Just refilling the text to a different width (or to take advantage of variable-pitch fonts) is already a problem in *info* buffers (because the underlying data doesn't clearly indicate the boundaries of paragraphs and doesn't clearly distinguish text from sample code, ...), so fine typography like avoiding those "rivers" is a fairly distant problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.