0

I'm using autocomplete and yasnippet, therefore I added

(define-key yas-minor-mode-map (kbd "<tab>") nil)
(define-key yas-minor-mode-map (kbd "TAB") nil)
(define-key yas-minor-mode-map (kbd "<C-tab>") 'yas-expand)

into my .emacs file. I use it in the LaTeX mode and everything works fine. However, opening a Fortran file the snippet completion does not working anymore. When I turn off AC mode and try to complete using <C-tab> I get the warning auto-complete-mode is not enabled which is confusing since I bound it to yas-expand.

However, the expand trigger from the menu works fine.

Do I have to add something to my .emacs file?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.