1

I want to color a word in emacs. So I open a somefile (C-x C-f somefile) and a write some silly sentence.

Now I want to colorize the word silly with yellow. So, with the mouse I chose Edit > Text Properties > Other and in the mini-buffer I write yellow.

Finally I save the file (C-x C-f) and close it (C-x k).

Now when I open the file again, the word silly will not appear in yellow.

The result is the same whether enriched-mode is set or not.

Can someone please explain me why?

This post is similar to the one found here Colors with enriched-mode which has no accepted answer and (unfortunately) a downvote, but no good explanation and that's the reason I post this question.

I'm running emacs 25.1.1.

  • 1
    The quasi-answer in a comment of the linked question is to use emacs 26.1. Can you update? The example there works for me in emacs 26.1. – Tobias Feb 25 '19 at 14:40
  • Have you tried enriched-mode? That's what it's for. See the Emacs manual, node Enriched Text. If you tried it and you had a problem, please specify your problem. Otherwise the question is not clear, so far. – Drew Feb 25 '19 at 15:29
  • @Tobias: thanks, it works. Please answer the post and I gladly accept your answer! – Eduardo Feb 25 '19 at 15:59
  • I've stressed Emacs version 26.1 in the answer to the linked question and voted to close this question as duplicate. Thanks for testing! – Tobias Feb 25 '19 at 16:07

Browse other questions tagged or ask your own question.