0

The following gif shows the behaviour quite nicely:

enter image description here

Whenever I type a space followed by a dot (.) in any mode derived from text-mode, emacs will replace the space with the dot. I could not want this behaviour, but couldn't figure out what causes this behaviour...

Anybody got any ideas?

6
  • 1
    Check what key . is bound to with C-h k ..
    – Tobias
    Feb 26 '19 at 10:49
  • Already did. It's self-insert-command
    – DeX3
    Feb 26 '19 at 11:19
  • Maybe you can identify suspicious active minor modes with (mapatoms (lambda (at) (when (and (boundp at) (member at minor-mode-list) (eq (symbol-value at) t)) (message "%s" at)))).
    – Tobias
    Feb 26 '19 at 11:55
  • 1
    Check the value of post-command-hook.
    – npostavs
    Feb 26 '19 at 13:17
  • 1
    Do you see the same thing when you start Emacs with emacs -Q (no init file)? If not, bisect your init file to find the culprit. And if it depends on what you've done interactively in your session then provide a recipe to repro the problem, starting from emacs -Q.
    – Drew
    Feb 26 '19 at 16:33
1

Found the culprit, it was a combination of aggressive-fill-paragraph-mode with whitespace-cleanup-mode. Setting afp-fill-keys to just space explicitly (used to hold space and . by default) fixes the problem.

  (setq afp-fill-keys '(?\ ))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.