0

When I try to evaluate a Quelpa expression that fetches a package from Github, it throws the following error

Debugger entered--Lisp error: (error "Command ’(env LC_ALL=C git clone https://github.com/ahobson/mac-classic-theme.el.git /Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/)’ exited with non-zero status 128: Cloning into '/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme'...\nfatal: could not read Username for 'https://github.com': Device not configured\n")
  signal(error ("Command ’(env LC_ALL=C git clone https://github.com/ahobson/mac-classic-theme.el.git /Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/)’ exited with non-zero status 128: Cloning into '/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme'...\nfatal: could not read Username for 'https://github.com': Device not configured\n"))
  error("Command '%s' exited with non-zero status %d: %s" ("env" "LC_ALL=C" "git" "clone" "https://github.com/ahobson/mac-classic-theme.el.git" "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/") 128 "Cloning into '/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme'...\nfatal: could not read Username for 'https://github.com': Device not configured\n")
  quelpa-build--run-process(nil "git" "clone" "https://github.com/ahobson/mac-classic-theme.el.git" "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/")
  quelpa-build--checkout-git(mac-classic-theme (:repo "ahobson/mac-classic-theme.el" :fetcher github :url "https://github.com/ahobson/mac-classic-theme.el.git") "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/")
  quelpa-build--checkout-github(mac-classic-theme (:repo "ahobson/mac-classic-theme.el" :fetcher github) "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme/")
  quelpa-build-checkout(mac-classic-theme (:repo "ahobson/mac-classic-theme.el" :fetcher github) "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme")
  quelpa-checkout((mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github) "/Users/amaro/.emacs.d/quelpa/build/mac-classic-theme")
  quelpa-build((mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github))
  quelpa-package-install((mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github))
  quelpa((mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github))
  eval((quelpa '(mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github)) nil)
  eval-expression((quelpa '(mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github)) nil nil 127)
  funcall-interactively(eval-expression (quelpa '(mac-classic-theme :repo "ahobson/mac-classic-theme.el" :fetcher github)) nil nil 127)
  call-interactively(eval-expression nil nil)
  command-execute(eval-expression)

Given fatal: could not read Username for 'https://github.com': Device not configured, it seems the issue relates to Github authentication issue but on the same machine ssh -T git@github.com successfully authenticates.

Should I configure something on the Emacs side to make it work with Github?

  • It looks like your remote is set up over https rather than ssh, so the fact that you can authenticate over ssh isn't relevant. Try (re)creating the remote and using ssh. – DoMiNeLa10 Mar 5 at 21:01
  • @DoMiNeLa10, thanks but the project is not mine, how do I set up a remote for other people's projects and make it uses ssh rather than https? – skyork Mar 5 at 22:15
  • 2
    Your :repo is wrong. Try going to github.com/ahobson/mac-classic-theme.el. It 404's. You should use ahobson/mac-classic-theme. – nega Mar 5 at 22:55
  • @nega, you're right, my mistake there. Issue fixed, though the error msg was a little misleading – skyork Mar 5 at 23:42
  • Great! Feel free to self-"answer and accept", as comments can disappear. – nega Mar 6 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.