0

I use markdown-mode for editing Markdown. When I'm trying to edit code blocks defined using backquotes (`) or multiple backquotes, my cursor skips over the backquotes, making it hard for me to edit them. It didn't always behave this way. How do I get the old behavior back, where there's nothing special about cursor movement around backquotes? (Or anywhere else.)

  • Do you see this behavior when you run emacs -Q? The -Q flag disables your personal and site-level init files. If you don't see this new behavior then try bisecting your init file until you find the cause of this new behavior. – nega Mar 11 at 19:55
  • I don't see how I can do that and still have markdown-mode accessible. (I suspect that it was a change in markdown-mode itself that's responsible, but it could be some more complicated combination of markdown-mode version with other factors.) – ceridwen Mar 11 at 20:21
  • Start emacs with emacs -Q your_file.md, then do Meta-x markdown-mode Ret to enable markdown-mode. – nega Mar 11 at 20:34
  • Meta-x markdown-mode says, "No match," presumably because I installed the package with MELPA and it lives in emacs.d/elpa/markdown-mode-VERSION. Is there a way around that? – ceridwen Mar 11 at 22:12
  • @ceridwen you should be able to M-x load-file and point it to the entry file of markdown-mode. – DoMiNeLa10 Mar 11 at 23:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.