2

I've just set up mu4e, and have noticed that when opening an attachment with the o key it will open with MuPDF. Pressing A w to open-with doesen't seem to help either, since it prompts for an external shell command.

I'd like to open PDF attachments with pdf-tools instead of MuPDF, or at least be able to open with with the open-with function mapped to A w

  • For me, pressing A e, for "in-emacs", opens the attachment in PDFView. Have you tried that? Also, o e works exactly the same. – Heikki Mar 17 at 8:55
  • You're right! I just tried it with another PDF file, and it worked out the box. I think the test PDF my friend sent me was missing the file extension, and so Emacs was opening the PDF as a text file. – Syne Mar 17 at 13:55
2

Recapping discussion in comments: Pressing A e, for "in-emacs", opens the attachment in PDFView. o e works exactly the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.