8

I just upgraded to Emacs 26.1 on Linux (Ubuntu 18.04, but emacs26 from the kelleyk repo).

python-mode is now bringing up a *Python-Help* window whenever the cursor in on a symbol or keyword. I'm finding this very distracting because it messes with my buffer layout and moves the cursor around.

It's a nice idea, but I don't want it happening automatically.

How can I disable the automatic *Python-Help* window?

  • Have you tried running Emacs without your init file (emacs -q)? – user12563 Mar 18 '19 at 21:54
  • If I do "emacs -q" it doesn't exhibit the bad behavior. However, evaluating everything in my .emacs; doesn't make it start (even after reloading the python file). So it's not something that I've configured. What does -q remove beyond my .emacs? – Dan Christian Mar 19 '19 at 16:10
  • Maybe it's related to when certain settings are set. – user12563 Mar 19 '19 at 17:49
  • The manual states for emacs -q: "Do not load your Emacs init file ~/.emacs, or default.el either. " ftp.gnu.org/old-gnu/Manuals/emacs-20.7/html_chapter/… – Lorem Ipsum Mar 19 '19 at 20:42
  • 3
    Disable eldoc – nega Mar 20 '19 at 17:11
4

nega nailed it. Turning off eldoc fixed my problems. I would have never know that was what to look for.

More detail here: How to globally disable eldoc?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.