2

I want to create file credenentials.txt in folder d:/dev/GoogleDrive/_IPTV/Playlists/OttClub/

M-x C-x C-f

enter image description here

Press "c" result:

enter image description here

press "cr" result:

enter image description here

As you can see Emacs change folder to d:/personal

I don't need this. I only want to create file in folder d:/dev/GoogleDrive/_IPTV/Playlists/OttClub/

How I can do this?

P.S. I also try by -Q mode and enable only ido-mode I get same result: enter image description here Press "cr" enter image description here

As you can see Emacs automatically change folder.

  • It seems to be not the ususal ido behaviour. Can you reproduce it with emacs -Q and ido-mode enabled? – andrej Mar 29 at 13:58
  • @andrej I updated my post. Not help. Same result – Alexei Mar 29 at 17:36
  • Don't know what is going on! Seems to be a bug to me. Maybe try updating emacs? As a workaround you can press C-f (after C-x C-f) to fall back to the usual find-file – andrej Mar 29 at 18:59
  • 2
    Is this what you're looking for? Either set ido-auto-merge-work-directories-length to a negative value, or increase the number of seconds in ido-auto-merge-delay-time. – jagrg Mar 30 at 9:53
  • @jagrg ido-auto-merge-delay-time - this help. Thanks – Alexei Mar 30 at 10:19
3

You should either set ido-auto-merge-work-directories-length to a negative value, or increase the number of seconds in ido-auto-merge-delay-time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.