2

when running Flymake against ~/.emacs, I see errors complaining about missing files like "powerline" and "company" - i.e. stuff contained in load-path. How can I configure Flymake's elisp backend to be aware of load-path? Nothing in the Flymake customize-group looked applicable.

This is with Emacs 27.0.50 .

1
  • This will not answer your question, but in case you were using Flycheck, this would be fixable by setting flycheck-emacs-lisp-load-path Sep 25, 2019 at 12:57

1 Answer 1

0

There is elisp-flymake-byte-compile-load-path. Setting it to load-path last in your init file seems to be a quick-fix.

(setq elisp-flymake-byte-compile-load-path load-path)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.