1

I tried (global-set-key (kbd "C-s-[") 'xxx) but when I use it I get:

<C-s-268632091> is undefined

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

closed as unclear what you're asking by Drew, DoMiNeLa10 Apr 10 at 18:24

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    How have you "tried"? How do you "use it"? Please clarify. – Stefan Apr 10 at 16:28
  • 3
    This is a previous bug that was fixed in the master branch a few months ago. Emacs 26.1; however, does not include the fix. (global-set-key (kbd "C-s-[") (lambda () (interactive) (message "hello-world"))) will work on Emacs 27.0.50 built --with-ns in the master branch. – lawlist Apr 10 at 19:22
  • @lawlist Thanks! – an0 Apr 11 at 2:03
  • OP: Please state your Emacs version. @lawlist: Consider posting your comment as an answer. Thx. – Drew Apr 11 at 13:38
  • You've now clarified "what you have tried", but not the "how do you use it". Tell us which keys you type (how did you get a "super" key?), under which OS/GUI, with which version of Emacs. – Stefan Apr 11 at 13:46

Browse other questions tagged or ask your own question.