1

I'd like to get access to org mode's extra keys. However, although the value of org-use-extra-keys is set to "on (non-nil)" (and has been for several Emacs sessions), I don't seem to have access to them. For example, when I enter the command describe-mode while visiting an org file, the extra key bindings are not displayed. In addition, if I type for example C-c C-x l, I get an error saying this command is not defined.

I'm on a Macbook Pro in Mojave, running the latest version of Emacs found on emacsformacosx.com.

Does anyone have ideas for how I could get these extra keys working?

0

What I see in the file, org.el, where these keybindings get defined is that the variable is only really checked at the time the module gets run. IMHO, this is a bug (if nothing else, loading in a GUI, then running emacsclient on the console will mean the keybindings aren't set as the author expects), but this means that the bindings will only be set once, and you need to make sure your setting takes effect before org.el runs. For instance, when I run emacs --eval '(setq org-use-extra-keys t)', I cannot use C-c C-x l. If, however, I skip the init files, set the variable, then explicitly load my dotfile (emacs -Q --eval '(setq org-use-extra-keys t)' -l ~/.emacs), I can run this keyboard macro with no problem.

So, I think you have two choices -- first, carefully structure your .emacs so there's no loading of org anything until after you do the set, or just manually define the keys you want in your dotfile and call it a day.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.