After calling org-babel-tangle on a certain file containing latex blocks, I see the prompt

No comment syntax defined. Use:

What is this about? This doesn't happen with another similar file I have.

PS. Minimal example (which I couldn't easily provide before seeing the answer):

#+BEGIN_SRC latek :tangle yes :comments link
  • 3
    Can you elaborate? It's hard to tell what's the cause of your problem without an example that causes the problem you've described. – DoMiNeLa10 Apr 16 '19 at 20:33
  • Please provide a recipe to reproduce what you see, starting from emacs -Q. It's not clear what you or Emacs did - the context. – Drew Apr 16 '19 at 21:09

It means some code somewhere within the execution of org-babel-tangle wants to do something that depends on the syntax of comments (which depends on the language being used) and for some reason Emacs hasn't gotten that info (which is usually provided by the major mode).

You can try and track it down by typing M-: (debug t) RET from within the above prompt which should show you the nesting of function calls which finally lead to the prompt.

  • it says i'm attempting to use the minibuffer while in the minibuffer – Toothrot Apr 16 '19 at 21:59
  • Then try M-: (setq enable-recursive-minibuffers t) RET before reproducing the problem. – Stefan Apr 16 '19 at 22:13
  • thanks! this led me to find a #+BEGIN_SRC latek line, correcting which solved the problem – Toothrot Apr 17 '19 at 0:06
  • @Toothrot: You might want to report this as a bug to the Org guys: you shouldn't need to do this kind of low-level debugging to catch this kind of typo. – Stefan Apr 17 '19 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.