1

I want to use pdf-tools to anotate pdf files using org-mode or viewing pdf outputs of my tex files which I hope it wil support syntex. I am following the official help to build for windows. I want to comprehensively tell my situation before and after the steps I've taken.

  1. I have cygwin, Imagemagick, git before being introduced to pdf-tools
  2. Emacs: I have a windows built not a cygwin built. I downloaded the 200 MB version of emacs 26.

Now following what Official help requires:

If using the GNU binaries for Windows, support for PNG and zlib must first be installed by copying the appropriate dlls into emacs’ bin/ directory. Most third-party binaries come with this already done.

I check the bin folder of emacs and these files were there: zlib.dll, libjpeg-8.dll, libpng16-16.dll. I tested to see if I can open PNG or JPEG files in emacs and I could. Then I installed msys2. Then I clicked start button typed msys and chose MSYS2 MinGW 64bit. Then I followed all the steps below:

$ pacman -Syu
$ pacman -S base-devel  
$ pacman -S mingw-w64-x86_64-toolchain  
$ pacman -S mingw-w64-x86_64-zlib
$ pacman -S mingw-w64-x86_64-libpng
$ pacman -S mingw-w64-x86_64-poppler
$ pacman -S mingw-w64-x86_64-imagemagick

For this step Install PDF tools in Emacs, but do not try to compile the server. Instead, get a separate copy of the source somewhere else. I went to Emacs folder and right-click on lib folder and clicked GITBash here, and then entered git clone https://github.com/politza/pdf-tools and this created a folder named PDF-Tools in lib folder with the size about 4MB. I don't know how to effect the next two steps, i.e.:

Open mingw64 shell (Note: You must use mingw64.exe and not msys2.exe)

Compile pdf-tools $ cd /path/to/pdf-tools $ make -s

I don't know where my mingw64.exe is located. Would you please help me. Thanks in advance.

P.S. I tried this command make install-server-deps on cygwin and also MSYS2 MinGW 64bit but both of them returned this: -bash: make: command not found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.