0

To quote,

By default, Auto-Revert mode works using file notifications, whereby changes in the filesystem are reported to Emacs by the OS. You can disable use of file notifications by customizing the variable auto-revert-use-notify to a nil value, then Emacs will check for file changes by polling every five seconds. You can change the polling interval through the variable auto-revert-interval.

Even auto-revert-use-notify is t, auto revert still polls for every 5 seconds. I want to disable such a polling because it results a block every time it polls. The block is due to the files are on a fuse mounted disk (via vmware).

2
  • Mounted filesystems cannot be watched by file notification. Likely, this is the reason autorevert continues to poll. Apr 24, 2019 at 11:59
  • 1
    Is switching off auto-revert-mode an option? If not, you should mention that in your question.
    – Tobias
    Apr 24, 2019 at 13:25

2 Answers 2

3

See https://debbugs.gnu.org/35418 - it discusses the problem.

1
  • This is an interesting discussion, thanks for the link. I was just wondering why auto-revert-avoid-polling isn't set to nil by default, and apparently that's the theme of the discussion. But please, could you provide a short summary of the discussion inside your answer? Otherwise it falls into "link-only" category, and is a subject to being removed.
    – Hi-Angel
    Aug 9, 2021 at 9:16
2

You can just set auto-revert-interval to a very large value (like most-positive-fixnum).

2
  • interesting workaround.
    – FunkyBaby
    Apr 25, 2019 at 3:29
  • the problem seems more involved because inotify is disabled until the next call of auto-revert-buffers, which is due to auto-revert-buffers-counter-lockedout
    – FunkyBaby
    Apr 25, 2019 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.