0

Sorry, but I will probably be not using the correct terminology in this post.

I used to be able to open Emacs from my terminal and the terminal process would stay open (I would not be able to navigate anywhere else using the terminal unless I opened a new tab of quit Emacs). It would look something like the following:

MacBook-Pro:~ User$ emacs



# and down here would just be open space

But now when I open Emacs, the terminal reverts back to where I can navigate to another directory or whatever:

MacBook-Pro:~ User$ emacs
MacBook-Pro:~ User$ 

However, I prefer the terminal process to stay open which allows me to easily close Emacs when it freezes (by just exiting the terminal) instead of powering off my computer. I am not sure what I did to cause this change in behavior.

  • You are saying that Emacs now automatically "backgrounds" the process (like emacs &)? In the past, did the terminal have emacs, or did it wait for your GUI version of emacs? When you type which emacs and emacs --version what do you get? – cyberbisson Apr 27 at 18:12
  • what causes emacs to freeze, by the way? – manandearth Apr 27 at 18:32
2

Your emacs is running as a background process for some reason.
I would have to guess why (see below).

You could try to get emacs back to foreground by running fg immediately after running emacs (do it at the same command prompt).

MacBook-Pro:~ User$ emacs
MacBook-Pro:~ User$ fg

Why is emacs running in the background: there are several possibilities

  • you assigned an shell alias, which runs emacs &, when you call emacs
  • you set up emacs to run in server-mode (i.e. with the --deamon option, this could also be an alias)
  • something else

Btw: here and here, you can read how to kill a process, which is frozen. So you do not need to reboot your computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.