1

If you use desktop-save-mode, and have several hundred buffers saved, when you start emacs, emacs cycles through these buffers and shows each of them for a split second. Can this be prevented?

  • Unclear what you mean by “re-open emacs.” Please clarify. – Dan May 1 at 17:52
  • 1
    Are you talking about re-opening a running emacs process via emacsclient, or restoring a previous session of Emacs via the desktop-save-mode, or are you doing something else? If you're using desktop-save-mode, check out the variable desktop-restore-eager – Tyler May 1 at 17:55
  • Great, Tyler, thanks, desktop-restore-eager was exactly what I was looking for. – Marius Hofert May 1 at 18:36
1

The variable desktop-restore-eager can control this. This variable controls how many buffers to restore the moment you start emacs. The rest will be restored quietly when Emacs is idle.

So if you set if for some low number, say 10, when you start Emacs it will immediately load 10 of your saved buffers. This will be fast enough to avoid the flickering you notice. After that, the rest of the buffers will be reloaded in bits and pieces when Emacs is idle.

The problem you describe is likely a consequence of the default value of desktop-restore-eager: t. This setting reloads all buffers before Emacs does anything else, so you have to sit and watch it happen before you can do anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.