0

I've used the solution suggested in this answer to automize the compilation of my LaTeX document using Arara upon entering C-c C-a. The resulting output is perfect, but the following erroneous message appears in the Emacs status bar: You should run LaTeX again. When I run arara on the same LaTeX document from the command line (not within Emacs), I get no such message.

Why is this message displayed? How can I get rid of it?

  • 1
    My guess: Because you're running under arara, you get the output of every latex run in the same output buffer, which auctex then searches for indications that a new run is needed. You could try setting TeX-parse-all-errors til nil and see if the problem goes away. There is a price to be paid for that, however, since you now lose some of the debugging features of auctex. – Harald Hanche-Olsen May 7 '19 at 11:10
  • @HaraldHanche-Olsen: Thanks. How can I test this theory? Where does AucTeX look for the arara output? – Evan Aad May 7 '19 at 11:50
  • 1
    If you want to see the code that does the parsing, look at the function TeX-LaTeX-sentinel. But really, it seems the first thing to do is to turn off TeX-parse-all-errors as I suggested. You can do it interactively with M-x set-variable, and see if it cures your problem – and what the side effects may be. If you want to make this fix permanently, put (with-eval-after-load 'tex-buf (setq TeX-LaTeX-sentinel nil)) in your emacs init file. – Harald Hanche-Olsen May 7 '19 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.