0

Whenever I run gud-print (C-xC-aC-p) with my cursor positioned on a variable while debugging with GUD (specifically via the gdb command), I get the message "Text is read-only" in the echo area. I can't figure out why this is happening. I tried (setq debug-on-message "Text is read-only") but never entered a backtrace after that message appeared again. I've tried various other Elisp debugging methods with no success (never entering a backtrace). I have tried running Emacs in a terminal and also X11; both attempts result in this error. I am using Cygwin if that makes a difference.

How can I get that message to go away and get gud-print to behave normally? Or better yet, what are some clever ways that I can diagnose this issue myself?

Edit for clarity: Variable values are not displayed anywhere. The only perceivable outcome of gud-print is the "Text is read-only" message being displayed in the echo area.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.