I am encountering a very strange problem. I worked with emacsclient for a while but suddenly, after starting an emacsclient frame the frame disappears shortly after start when interacting with it. It seems that the process keeps running but the frame is just gone.

The server is running, restarting it don't change anything. I am using emacs now again, because it works fine. I also can start emacsclient -t to run in terminal, which is also working fine. Just using emacsclient -c stopped working as expected.

I also tried emacsclient -e "(make-frame)". This worked once, now stopped working with error message *ERROR*: Unknown terminal type.

I am using Ubuntu 18.04 with standard bash. Emacs is 27.0.50, built from source, GTK+ Version 3.22.30.

Maybe someone knows what I am doing wrong or can give me a hint how to debug this.

1 Answer 1


Found the answer. Stupid me, most of the time it is a good idea checking newly used packages.

I have tried a very early version of which-key-posframe which seems to have caused this problem. The package developed, the issue was related to this Github Issue, which is fixed and now emacsclient is working fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.