0

This question already has an answer here:

I am trying to use Magit but whenever I tried running it, somehow fonts are not rendered properly.

I am using MacOS and below is the init.el config. I am using powerline font (Meslo)

(use-package dash
:config (dash-enable-font-lock)) // checked with or without it

(use-package magit
  :defer t
  :bind (("C-x g"   . magit-status)
         ("C-x M-g" . magit-dispatch))
  :config
  (magit-add-section-hook 'magit-status-sections-hook
                          'magit-insert-modules
                          'magit-insert-stashes
                          'append))


^[[33mdiff --git Network.playground/Pages/NetworkKit.xcplaygroundpage
/Contents.swift Network.playground/Pages/Network$
^[[33mdeleted file mode 100644^[[m                                                                                    
^[[33mindex 9b5290a1674f..000000000000^[[m                                                                            
^[[33m--- Network.playground/Pages/NetworkKit.xcplaygroundpage/Contents.swift^[[m                                     
^[[33m+++ /dev/null^[[m                                                                                               
^[[35m@@ -1,248 +0,0 @@^[[m                                                                                           
^[[31m-import UIKit^[[m                                                                                               
^[[31m-import RxSwift^[[m                                                                                             
^[[31m-import os.log^[[m                                                                                              
^[[31m-^[[m                                                                                                           
^[[31m-// Enums to simplify the Network Kit^[[m                                                                       
^[[31m-enum HTTPMethod: Equatable {^[[m                

I tried removing powerline font and using system font but still the text are rendered like above.

marked as duplicate by npostavs, tarsius magit Jun 5 at 12:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.