1

I had this error message displayed to me by AUCTeX (already corrected using \ddot{\boldsymbol x})

ERROR: Extra }, or forgotten $.

--- TeX said ---
<recently read> }

l.51 \[ \boldsymbol M\ddot\boldsymbol
                                      x + \boldsymbol K\boldsymbol x =
--- HELP ---
括弧または数式モードのデリミタが正しく対応していません.おそらく{・\[・
\(あるいは$のうちのいずれかを書き忘れたのでしょう.

Google's Translate says it's Japanese...

In the *scratch* buffer I have

(getenv "LANG")
"C.UTF-8"

I'm on Debian Sid with an updated Debian TeXLive and auctex-12.1.2 installed with elpa

What's going on?


Addendum

I had consistently the help message in Japanese using either pdflatex or xelatex or luatex while from the shell I had, in all cases, the help message in English. Both in Emacs and the shell I have LANG set to C.UTF-8.

The problem was solved (so to say) restarting Emacs. In a new copy of Emacs, with a new instance of AUCTeX I have again the help messages in English.

The strange behaviour I experienced is likely due to a casual interaction between the user and Emacs/AUCTeX and I don't expect that we can find what happened, on the other hand I don't want to remove the question but it's fine if you close it.

8
  • What is the documentclass of your tex file? – Fran Burstall Jun 6 '19 at 16:17
  • @FranBurstall \documentclass[a4paper]{article} – gboffi Jun 6 '19 at 16:34
  • Is your locale the same outside of Emacs? Try spawning a shell in a terminal outside of Emacs and looking at LANG inside of it. – user12563 Jun 6 '19 at 19:52
  • @DoMiNeLa10 My locale is C.UTF-8 in the shell and in the X session. Emacs was started from the window manager that, in turn, was started by my ~/.Xsession (I know, very old fashonied, isn't it?). I add that I don't see Japanese very often, not at all... – gboffi Jun 6 '19 at 20:57
  • What happens if you run latex, eg pdflatex file.tex, on the file outside emacs in a shell? – Fran Burstall Jun 7 '19 at 17:12
1

A brute force search over the AUCTeX documentation points me to this node, of which the last paragraph says the following.

See ‘tex-jp.el’ for more information.

Then I look at the source of tex-jp.el and find the following lines.

(defcustom japanese-TeX-error-messages t
  "*If non-nil, explain TeX error messages in Japanese."
  :group 'AUCTeX-jp
  :type 'boolean)

...

(if japanese-TeX-error-messages
(setq TeX-error-description-list
  '(("\\(?:Package Preview Error\\|Preview\\):.*" .
"`preview'へ`auctex'オプションを直接与えるのは避けてください.
プレビューの実行時以外でこのエラーが出た場合,余りにこみいったことを
しすぎか,でなければAUCTeXがひどい失敗をしています.")

...)

We should probably set the variable japanese-TeX-error-messages to nil in the init file or using the Easy Customization Interface. Restart Emacs now and Japanese shall never appear again now.

We should probably file an issue to the AUCTeX maintainer and this option should be set to nil by default instead of t.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.