1

I have a number of org-mode/text documents that contain English and Hebrew text. They are scholarly papers. However, the Hebrew text in Emacs is not displayed correctly. I am using Dejavu Sans Mono as my font. The problem is that vowels are displayed next to the consonants rather than beneath them. There are a few other anomalies too. If I export the documents in org mode to html or odf then the Hebrew is displayed correctly. I have tried changing the font, installing "unicode-fonts" and a host of other solutions. I have tried using different versions of Emacs. I use utf-8 as my default encoding system. Nothing seems to work. If I open the same text document in LibreOffice, again, the text is displayed correctly. If I strip the Hebrew text of vowels, using an online program (like https://www.miniwebtool.com/) then the consonants appear correctly in Emacs when pasted back. The problem is that I need the vowels too. I also have other academic papers with Greek, and these display correctly without any problems. I would appreciate any help with this problem.

  • If auto-composition-mode is nil, the characters will be displayed separately instead of being composed into one unit; e.g., a Hebrew character with vowels. Type C-h v aka M-x describe-variable to check the value in the buffer at issue -- it is a permanent buffer-local variable if set. – lawlist Jun 10 at 5:39
  • In my case though auto-composition-mode changes the display, in both cases, the Hebrew text remains incorrectly displayed. – devcom Jun 10 at 8:42
  • 2
    @devcom Please consider submitting a bug report with M-x report-emacs-bug RET, as this includes vital information such as your Emacs version and its build configuration, without which it is hard to debug your problem. For example, one possible cause of bad Hebrew diacritic shaping is the lack of a shaping engine such as m17n-flt. Please also try to provide a minimal reproduction recipe starting from emacs -Q, so as to rule out any user or system-wide configuration settings. – Basil Jun 10 at 9:46
  • Thank you. Shall do. – devcom Jun 11 at 15:12
1

This issue has now been fixed in the latest git version of Emacs thanks to help from Eli Zaretskii.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.