2

I want to use helm for org-refile completion when determining which heading to refile under.

Here are some excerpts from my initialization script.

(setq org-refile-targets '(("~/Documents/GTD/Gtd.org" :maxlevel . 3)
                           ("~/Documents/GTD/Someday.org" :level . 1)
                           ("~/Documents/GTD/Tickler.org" :maxlevel . 2)))


(setq org-outline-path-complete-in-steps nil)
(setq org-completion-use-ido nil)

I'm not sure what more I need to use helm in this manner. Do I need to rebind the refile key to a different command?

1 Answer 1

5

Here are my settings. I got a lot of help on this from Aaron Bieber's discussion.


(setq org-refile-targets '((org-agenda-files :maxlevel . 8)
                           ("~/.emacs.d/config.org" :maxlevel . 8)))
(setq org-refile-use-outline-path 'file)
(setq org-outline-path-complete-in-steps nil)
(setq org-refile-allow-creating-parent-nodes 'confirm)

Helm works perfectly with these settings. I didn't have to set org-completion-use-ido to nil. I actually don't see that as a variable option at all (I'm using org 9.2.4).

2
  • Doesn't seem to be working for me with those settings. I am running on Windows so not sure if that makes a difference.
    – Phaino
    Jun 20, 2019 at 21:14
  • Actually, this does work I just had an error in my config. Thank you!
    – Phaino
    Jun 21, 2019 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.