0

When I invoke C-u M-x shell while visiting a local file or scratch buffer, emacs does not prompt me to enter the default directory for the shell.

But if I'm visiting a remote file or directory through tramp, then when invoking C-u M-x shell, emacs will ask me for the default directory.

How can I make C-u M-x shell ask for the default directory even when I'm visiting a local file or buffer?

0

This is not foreseen in the code of shell. It asks for a default directory only in case the current default directory is remote. The comment says

;; It must be possible to declare a local default-directory.

If you want an option to be asked at every invocation of shell, you might write a wishlist report via M-x report-emacs-bug.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.