1

Whenever I type YouTrack, abbrev erroneously corrects it to Youtrack. I noticed that in my abbrevs file it has ("youtrack" "youtrack" nil :count 7). Why is that there, and how can I get abbrev to correctly capitalize it YouTrack?

I'd actually prefer if it corrected Youtrack to YouTrack but editing the abbrevs file to that affect seems to change nothing about the behavior. The only flag that sounds remotely germane is abbrev-all-caps, but that doesn't change the behavior to what I want.

0
1

Changing the replacement string from youtrack to YouTrack with M-x edit-abbrev RET is working for me.

Afterwards I get YouTrack if I type youtrack.

Test conditions: emacs-version: 26.1 build 2, Emacs called with emacs -Q

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.