0

I am having a problem with loading a second java file in xemacs 21.5.34-17.6 on NAME="openSUSE Tumbleweed" VERSION="20190721"

The first java file loads with no problem. If I try to load a second java file I get the following error.

Debugger entered--Lisp error: (void-variable #:--letf-bound--95839)
  signal(void-variable (#:--letf-bound--95839))
  byte-code("..." [buf data kill-buffer signal] 3)
  find-file-noselect("~/tmp/tmp/test1.java" nil nil t)
  #<compiled-function (from find-file) (filename &optional codesys wildcards) "...(37)" [wildcards filename coding-system-for-read thunk value codesys check-coding-system find-file-noselect nil #<compiled-function (from "/home/abuild/rpmbuild/BUILD/xemacs-21.5.34/lisp/files.elc") ... "...(21)" ... 3 0x7e9> mapcar] 5 1286493 (list (read-file-name "Find file: ") (and current-prefix-arg ...) t) 0x7ea>("~/tmp/tmp/test1.java" nil t)
  call-interactively(find-file)

I did not have this problem with xemacs version 21.5.34-2.1.4 on NAME=openSUSE VERSION="13.1 (Bottle)"

There are no differences in the files.el between versions

Tried posting to xemacs-beta but got a server error.

  • Indeed curious... Things to try in order 1) make sure your upgrade was clean 2) try again after getting rid of the bytecompiled file files.elc, and files.el is there and uncompressed 3) file an issue at bitbucket.org/xemacs, probably under xemacs-beta or xemacs-base 4) file an issue with SUSE. You probably don't want to hear it, but you should invest the time into switching to Emacs. XEmacs' time is sadly over. (SXEmacs would be a more XEmacs-like option too) – nega Jul 24 '19 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy