0

Upon reading epub on emacs, I tried https://github.com/wasamasa/nov.el.

Installed and configured step by step as its instructions.

When C-x C-f to open an epub, it is displayed as

M Filemode      Length  Date         Time      File
- ----------  --------  -----------  --------  -------------------------------------------
  -rw-rw-rw-        20  17-Apr-2019  15:56:18  mimetype
  -rw-rw-rw-     17950  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_1607.png
  -rw-rw-rw-     27202  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_1603.png
  -rw-rw-rw-     26145  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_1602.png
  -rw-rw-rw-     59360  17-Apr-2019  15:56:18  OEBPS/ch07.html
  -rw-rw-rw-     45564  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_1801.png
  -rw-rw-rw-     55767  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_1202.png
  -rw-rw-rw-     15460  17-Apr-2019  15:56:20  OEBPS/content.opf
  -rw-rw-rw-     41249  17-Apr-2019  15:56:20  OEBPS/assets/dsf2_0503.png
  -rw-rw-rw-    110635  17-Apr-2019  15:56:20  OEBPS/ix01.html

Recall the instruction, I cannot follow the sentence.

  You'll also need an Emacs compiled with libxml2 support, otherwise rendering will fail.

What does compiled with ... support?

Does it mean that if you want this tiny dispensable function, than have to take risks to reinstall emacs?

2

Try M-x nov-mode to turn it on before you decide it's not working.

0

Re-compiling emacs may not be necessary if your libxml is in a standard location by pk-config. Have you actually tried to use nov.el and does it fail? If libxml is in a non-standard location then you use LIBXML2_LIBS flag to specify where it is. See ./configure --help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.