0

I'm getting the "no more undo" message all too often, even I made changes that should be there in the history. This is seriously breaking my workflow.

This is my .emacs

https://github.com/skrat/dots/blob/master/emacs/.emacs

  • 1
    As I peer into my crystal ball, I see that perhaps the O.P. has left undo-tree-enable-undo-in-region at its default setting of non-nil and that the O.P. has an active region. If that sounds like a possibility, then try (setq undo-tree-enable-undo-in-region nil). That will also avoid the O.P. encountering a different long-standing bug: emacs.stackexchange.com/a/37399/2287 Another possibility is that the undo-limits are too low and the undo-tree history is being truncated as a result ... the limits should be raised ...: undo-limit, undo-strong-limit, undo-outer-limit – lawlist Aug 1 at 21:34
  • @lawlist feel free to post it as an answer, I niled undo-tree-enable-undo-in-region and now I'm waiting, I mean, working, time will show. – skrat Aug 2 at 17:12
1

There are two (2) likely suspects:

I. undo-tree-enable-undo-in-region is at its default non-nil setting and the O.P. has an active region; i.e., there are no more available undos in that active region. In such a case, try:

(setq undo-tree-enable-undo-in-region nil)

The above-mentioned setting will also avoid the O.P. encountering a different long-standing bug:

https://emacs.stackexchange.com/a/37399/2287

II.  Another possibility is that the undo-limits are too low for the needs of the O.P. and the undo-tree history is being truncated as a result .... In such a case, the limits may be raised for the following variables (depending upon system hardware, etc.):  undo-limit, undo-strong-limit, and undo-outer-limit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.