1

I'm using evil-mode and olivetti-mode, which adjusts the margins so that the text is centered in the window. My screen usually looks like this:

               Voluptatem tempore unde eveniet cumque dolores
               aliquid veritatis. Rem ea voluptas sed minus qui
               illo. Magni reiciendis excepturi dolorem. Est
               pariatur sed rerum. Quis nobis laboriosam sint
               ut qui neque.

               Inventore quod eveniet tenetur quod doloribus
               possimus. Aut sed est sunt id sit nihil. Minima
               aut eius quas. Enim voluptatem quos et
               cupiditate consequuntur voluptatem aut sint.
               Voluptates maxime in autem ut. Voluptatem quasi
               vel neque tenetur illo quod.

               Iure cumque ut quas sapiente. Id voluptatibus
               vero libero ipsum. Quaerat consequuntur quam
               accusamus. Impedit illo sed aut quia sit.

               Autem saepe perferendis vero. At deleniti
               nesciunt sunt molestiae quo. Qui ab et quam ut.
               Est est ut mollitia sunt.

-UU-:----F1  test.md        Top L2       (Markdown Olv Undo-Tree ElDoc Wrap) 

However, when I run a command, the margins get set to zero, and my screen looks like this:

Voluptatem tempore unde eveniet cumque dolores aliquid veritatis. Rem ea
voluptas sed minus qui illo. Magni reiciendis excepturi dolorem. Est pariatur
sed rerum. Quis nobis laboriosam sint ut qui neque.

Inventore quod eveniet tenetur quod doloribus possimus. Aut sed est sunt id
sit nihil. Minima aut eius quas. Enim voluptatem quos et cupiditate
consequuntur voluptatem aut sint. Voluptates maxime in autem ut. Voluptatem
quasi vel neque tenetur illo quod.

Iure cumque ut quas sapiente. Id voluptatibus vero libero ipsum. Quaerat
consequuntur quam accusamus. Impedit illo sed aut quia sit.

Autem saepe perferendis vero. At deleniti nesciunt sunt molestiae quo. Qui ab
et quam ut. Est est ut mollitia sunt.

Consequatur inventore qui sequi exercitationem necessitatibus necessitatibus
sed iusto. Beatae tempora sit quia. Aliquid sed nulla quia.

Consequatur quia nisi in. Adipisci alias et magnam quia voluptatem ut. Modi
optio et aut iste saepe laboriosam. Rem exercitationem sed similique
laboriosam eum dolor. Et sit autem ea non. Dolorem omnis enim eos cum.
-UU-:----F1  test.md        Top L2       (Markdown Olv Undo-Tree ElDoc Wrap) 
:!wc -w %

This is incredibly annoying. I want the text I'm editing to stay in place while I run a command.

I get the same problem with other plugins that modify the margins, such as linum-mode. As far as I can understand, the margins are being adjusted to match the margins of the minibuffer, which is zero. So, to fix this problem, I need to either add a margin to the minibuffer, or disable this behavior. However, I'm not sure how to do either of those thing. Is there a way?

  • 1
    Part of the problem is the primitives for managing the margins, which don't provide any easy way for packages to collaborate, but I recommend you file bug reports against linum-mode, olivetti, and evil about this. – Stefan Aug 26 '19 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.