0

I recently started using Org as my planner. While I was trying to setup PROPERTIES, I found the manual says:

If you want to set properties that can be inherited by any entry in a file, use a line like: #+PROPERTY: NDisks_ALL 1 2 3 4

So I did something like:

#+PROPERTY: Effort_ALL 00:10 00:30 01:00

on the top of my org file.

Now when I go to one of the entries and hit C-c C-x e TAB, it tells me "No Match". When I try to put in the Effort property first by C-c C-c p and then try to use S-TAB on the generated Effort property, it says "Allowed values for this property have not been defined", which obviously is saying that the #+PROPERTY line does not exist.

I can do lines like this without any issue. That is, there's auto-completion and I can do S-TAB to cycle through defined values.

   * CD collection
   :PROPERTIES:
   :NDisks_ALL:  1 2 3 4
   :Publisher_ALL: "Deutsche Grammophon" Philips EMI
   :END:

A bit background info:

Windows 10 pro

Emacs 26.2 (build 1, x86_64-w64-mingw32)

Using Org-Evil (turned it off but the problem still persisted)

  • Did you type C-c C-c on the #+PROPERTY: line after you entered it? Or restart emacs and reread the file? This is usually the cause of the problem in such cases. – NickD Sep 7 at 2:06
  • Hi @NickD, I didn't type C-c C-c but did restart emacs. I'll try later see if C-c C-c works. Never occurred to me I needed to do that tho. – yatsky Sep 12 at 23:48
  • See the Setting up keywords for individual files section in the manual, although if you restarted emacs after changing the file, it should have worked (see the footnote in that section). BTW, it does work for me. – NickD Sep 13 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.