0

I use mu4e and sometimes I cannot find a message with a search term including a period. For example, if I search for Google.org, I see:

No matching messages found

but if I search for "impact challenge", I see a message with Google.org in the subject line:

8660  28/06/2019 PS   noreply@withgoo... Google.org Impact Challenge on Safety: Submission Received      

I am able to find messages when the period is in the email address, e.g. the above message when I search for withgoogle.com.

The documentation on searching does not mention a special role for periods.

Am I missing something or is this a bug?

Update: here is the raw message with headers up to the body, replacing emails, IP addresses, signatures, and the like with <>. The period is in the From header.

Return-Path: <>
Delivered-To: unknown
Received: from <> (<>) by <> with
  POP3-SSL; 17 Jun 2019 15:41:16 -0000
Delivered-To: <>
Received: from <> ([10.2.0.17])
    by <> (Dovecot) with LMTP id O82AO0mkB10uMQAAZlJlVA
    for <>; Mon, 17 Jun 2019 15:37:08 +0100
Received: from <> ([127.0.0.1])
    by <> (Dovecot) with LMTP id RUIOEYJjB13EOAAAqE/zKQ
    ; Mon, 17 Jun 2019 15:37:08 +0100
Received: from localhost (localhost [127.0.0.1])
    by <> (Postfix) with ESMTP id 5284020143
    for <>; Mon, 17 Jun 2019 15:37:08 +0100 (BST)
X-Quarantine-ID: <XZvr36t3mmiF>
X-Virus-Scanned: Debian amavisd-new at <>
Authentication-Results: <> (amavisd-new);
    dkim=pass (2048-bit key) header.d=google.com
Received: from <> ([127.0.0.1])
    by localhost (<> [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id XZvr36t3mmiF for <>;
    Mon, 17 Jun 2019 15:37:07 +0100 (BST)
Received: from <> (<> [209.85.222.173])
    by <> (Postfix) with ESMTPS id BD3D75F99A
    for <>; Mon, 17 Jun 2019 15:37:05 +0100 (BST)
Received: by <> with SMTP id r6so6322105qkc.0
        for <>; Mon, 17 Jun 2019 07:37:05 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=20161025;
        h=mime-version:references:in-reply-to:from:date:message-id:subject:to;
        bh=<>;
        b=<>
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:references:in-reply-to:from:date
         :message-id:subject:to;
        bh=<>
        b=<>
X-Gm-Message-State: <>
X-Google-Smtp-Source: <>
X-Received: by 2002:a37:696:: with SMTP id <>;
 Mon, 17 Jun 2019 07:37:04 -0700 (PDT)
MIME-Version: 1.0
References: <>
In-Reply-To: <>
From: "Google.org Impact Challenge on Safety" <safety-challenge@google.com>
Date: Mon, 17 Jun 2019 15:36:27 +0100
Message-ID: <>
Subject: Re: Scope of the safety challenge
To: Miguel Morin <>, safety-challenge@google.com
Content-Type: multipart/alternative; boundary="0000000000000bc240058b85ee74"

--0000000000000bc240058b85ee74
Content-Type: text/plain; charset="UTF-8"
  • 1
    Question seems too general to isolate the issue. I've done a few searchs and I haven't had any trouble with dots in search (v1.2.0 and 1.3.4) . I'd check searching using from: or whatever and see what happens. When I had misbehaviors (once or twice in 4 years) either reindex or rebuild the database worked to me. – Muihlinn Sep 21 '19 at 5:49
  • I tried with from: and subject: and still do not find the message. I updated the index with mu4e-update-index and still do not find the message. I could not find how to rebuild the database. @Muihlinn how do you do it? – miguelmorin Sep 22 '19 at 11:50
  • mu index --rebuild --maildir="yourmaildir" should be enough. mu index --maildir="yourmaildir" --muhome="yourmuhome" will do it if you delete your current mu home. Please notice that one thing is your mail place and another the place for the mu database, they should match your mu4e configuration. @miguelmorin. – Muihlinn Sep 22 '19 at 13:24
  • 1
    Now that I've fully figured what you're looking to achieve, I've had some similar issues, looking for reproducible steps to post an issue in github. – Muihlinn Sep 23 '19 at 18:13
  • 1
    FYI github.com/djcb/mu/issues/562 – Muihlinn Sep 24 '19 at 19:24
1

As you can see in this issue those characters are problematic in some cases. The problem there is:

Searching for domain names "abc.domain.com" or IP addresses "10.20.30.40" fails even though the messages are indexed and can be found by searching for other english words in them. It seems searching for strings containing dots, slashes, etc. fail without error (just return no results)

and the author replied:

Sadly, due to the way the Xapian indexing / querying works (which mu uses), searches for such strings are problematic... not much I can do about that. ... Using spaces might help indeed; xapian sees the '.' as a word-separator.

So you can search using the words and avoiding the dots, i.e. from:google org in your example.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.