I am totally new to Emacs and on this first day I am trying to do very basic stuff in emacs. I am stuck at switching buffers when there is a terminal window open (by using M-x term). The next buffer command changes from <XF86Forward> to C-c C-<right>. I tried to type Ctrl + c + Ctrl + -> on the keyboard, but it still doesn't work. What is the problem here?

P.S. I am using macOS Mojave and Emacs 26.1.

1 Answer 1


C-<right> (sometimes written <C-right>) means press and hold the Control key while hitting the <right> key. The <right> key is the right-arrow key.

Emacs key notation is described here: (emacs) User Input.

You can get to that doc within Emacs, by doing this: C-h r i keyboard input.

That is:

  1. Use C-h (Control + h) followed by r to visit the Emacs manual.
  2. Use i followed by inputting the text keyboard input.

In a manual, i looks things up in the Index. Looking up keyboard input it puts you in the manual node User Input.

  • I tried doing it but no new line showing C-c C-<right> on the Message buffer, while C-c s-<right> can be produced when I held and pressed the command key for s on mac. Why doesn't my C-<right> work?
    – ark
    Sep 25, 2019 at 19:23
  • Found the answer here. After deselect these shortcuts I can use this command. Thanks a lot!
    – ark
    Sep 25, 2019 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.