1

I'm trying to install emacs 26.3 on debian 10. After the download :

./configure
sudo make
sudo checkinstall

during the checkinstall, I have the following error :

 rm -f "/usr/local/share/emacs/26.3/lisp/subdirs.el"
 umask 022; ../build-aux/update-subdirs 
 "/usr/local/share/emacs/26.3/lisp"
 subdir="/usr/local/share/emacs/26.3/site-lisp" ; \
   if [ -f "${subdir}/subdirs.el" ]; then true; else umask 022; 
 /usr/bin/mkdir -p "${subdir}"; (echo "(if (fboundp 'normal-top-level- 
 add-subdirs-to-load-path)"; echo "    (normal-top-level-add-subdirs- 
 to-load-path))") > "${subdir}/subdirs.el"; fi
 subdir="/usr/local/share/emacs/site-lisp" ; \
   if [ -f "${subdir}/subdirs.el" ]; then true; else umask 022; 
 /usr/bin/mkdir -p "${subdir}"; (echo "(if (fboundp 'normal-top-level- 
 add-subdirs-to-load-path)"; echo "    (normal-top-level-add-subdirs- 
 to-load-path))") > "${subdir}/subdirs.el"; fi || true 
 [ -z "/usr/bin/gzip" ] || { \
   echo "Compressing *.el etc. ..." && \
   cd "/usr/local/share/emacs/26.3/lisp" && \
   for f in `find . -name "*.elc" -print | sed 's/.elc$/.el/'`; do \
     /usr/bin/gzip -9n "$f"; \
   done; \
   /usr/bin/gzip -9n "../etc/publicsuffix.txt"; \
 }
 Compressing *.el etc. ...
 gzip: ../etc/publicsuffix.txt: No such file or directory
 make: *** [Makefile:571: install-arch-indep] Error 1

 ****  Installation failed. Aborting package creation.

How can resolve this issue ?

3
  • 1
    Why the checkinstall? Is this the recommended procedure?
    – JeanPierre
    Oct 1 '19 at 16:26
  • 1
    Also, why use sudo for make? There's no reason not to build as a normal user.
    – JeanPierre
    Oct 1 '19 at 19:31
  • normally, checkinstall replace make install. But it seems it doesn't worked for this installation ...
    – Kafka
    Oct 2 '19 at 7:31
1

You missed a step, after you run the make command, you need to run make install prefix=/replace/with/destination/path. You also do not need to use sudo during the make command, but you may have to use sudo during the make install step depending on where you want to install Emacs.

3
  • You can also ./configure --prefix=/usr/local (or wherever you wish), and subsequent commands will then use that prefix by default.
    – phils
    Oct 1 '19 at 23:27
  • ok thank you, it's worked. But I can't use checkinstall package which allow easy remove of package that are not in the repository ...
    – Kafka
    Oct 2 '19 at 7:30
  • @Kafka You can use the make uninstall command though (this will remove all files that were installed).
    – preetpalS
    Oct 3 '19 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.