0

My problem is - the whitespace mode is only showing dots for whitespaces in fundamental mode, however in other modes, like clojure, when whitespace mode is active - nothing happens.

I expect the whitespaces to be drawn as dots in clojure mode as well. I enabled the global whitespace mode, but it also doesn't help.

Any ideas how to fix this?

Basically, I'd like to enable whitespace mode everywhere

PS. have been searching for the already asked question but didn't find any PPS. I am using doom emacs

  • The visible whitespace dots are created by adding relevant entries to a buffer-local variable called the buffer-display-table. I do not use a current version of org-mode, but my recollection is that it uses its own buffer-local setting for the buffer-display-table for things like the org-ellipsis at the end of lines that are folded (hiding certain successive lines underneath) -- i.e., org-display-table. What happens if you manually disable and enable M-x whitespace-mode after the major-mode in question is fully loaded? – lawlist Oct 5 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.