0

When I do pulse-momentary-highlight-region, the highlight stays till I press any key.

(I'm on macOS emacs -nw.)

How can I make the pulse to go away after a short while?

  • Maybe see if you see the same thing when starting with emacs -Q (no init file). If you do, consider posting a step-by-step recipe to repro it, in a bug report: M-x report-emacs-bug. – Drew Oct 16 '19 at 1:45
0

Type M-x find-library RET pulse RET and have a peek at the variables defined with defcustom and defvar -- you can use isearch ....

How about customizing the following three variables?:

pulse-iterations: "Number of iterations in a pulse operation." [The default value is 10.]

pulse-delay: "Delay between face lightening iterations." [The default value is .03.]

pulse-flag: "Whether to use pulsing for momentary highlighting. ..." [The default value is determined by the function (pulse-available-p).] The doc-string is semi-lengthy and has been truncated here for simplicity purposes.

| improve this answer | |
  • pulse-available-p is nil for me – american-ninja-warrior Oct 16 '19 at 2:06
  • It looks like the function depends on the background of the default face: (condition-case nil (let ((v (color-values (face-background 'default)))) (numberp (car-safe v))) (error nil)). I would suggest setting the variable with a t and see if that gives you the desired result: (setq pulse-flag t). – lawlist Oct 16 '19 at 2:09
  • In addition, also check to see whether your default face has a background color that is recognized by your setup; e.g., that you did not make a typo in the hex or English name of the color; and, that your setup can take advantage of the color you have selected. Try using something simple, like a "yellow" or "blue" background to do some troubleshooting .... – lawlist Oct 16 '19 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.