0

I use company-mode for auto-completion and sometimes I have a strange problem with Emacs-Lisp. Variables are not shown among the completion candidates. Sometimes, if shown, pressing <f1> doesn't open any documentation. I have to shut down Emacs and reboot. This behavior seems to be completely random. Any hint?

(By the way: this used to happen also when I was using auto-complete-mode)

6
  • 1
    I guess this depends on the company backend. For which language do you get this behaviour? Dec 12, 2014 at 14:58
  • I edited the question. I was referring to Emacs-Lisp. Thank you.
    – petrux
    Dec 12, 2014 at 15:59
  • Can you reproduce the problem reliably?
    – Dmitry
    Dec 15, 2014 at 1:58
  • No. It's quite random.
    – petrux
    Dec 15, 2014 at 8:44
  • Ok. But if you have that problem in a given session, does it remain if you abort and re-initiate completion, or is it most likely gone?
    – Dmitry
    Dec 16, 2014 at 18:21

1 Answer 1

3

Judging by the issue, the author of this question expected to see the documentation for variables from a package that hasn't been loaded yet.

M-x describe-variable won't show it either, so it's not a bug.

4
  • Just tested. M-x describe variable works fine but I still cannot see among the completion candidates e.g. org-agenda-block-separator if I'm inside a custom command's settings. Let me explain better. In this case: (setq org-agenda-b...) I can see the variable among the completions, but in the case of (setq org-agenda-custom-commands '(("b" "Test" (...) ((org-agenda-b...))))), I cannot.
    – petrux
    Dec 28, 2014 at 17:21
  • @petrux That seems to be a bug in elisp-completion-at-point (which was called lisp-completion-at-point until recently). You should M-x report-emacs-bug.
    – Dmitry
    Dec 28, 2014 at 22:14
  • @petrux Thanks. If no one beats me to it, I should get around to it in a few days.
    – Dmitry
    Jan 19, 2015 at 4:22
  • 1
    @petrux And it's fixed now. Sorry it took a while.
    – Dmitry
    May 3, 2015 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.