2

Having here some troubles with TRAMP mode and already set (customize-set-variable 'tramp-verbose 6 "Enable remote command traces") in .emacs file.

But main problem is that Emacs is stuck in TRAMP mode, and debug buffer can't be accessed.

Hangs while copying large files via scp to remote to local network, it hangs on Encoding in base64. Already set (setq tramp-inline-compress-start-size "800000000"), (setq tramp-copy-size-limit "800000000") and (customize-set-variable 'tramp-verbose 6 "Enable remote command traces").

Anyway there would be log files to access?

  • Can you provide a step-by-step recipe to reproduce the problem? Do you see the same thing if you start Emacs using emacs -Q? (If not, bisect your init file to find the culprit.) – Drew Oct 24 at 14:52
  • Hangs while copying large files via scp to remote to local network, it hangs on Encoding in base64. Already set (setq tramp-inline-compress-start-size "800000000"), (setq tramp-copy-size-limit "800000000") and (customize-set-variable 'tramp-verbose 6 "Enable remote command traces"). – Renan41 Oct 24 at 15:00
  • Please put all such info in the question itself. Comments can be deleted at any time. Thx. – Drew Oct 24 at 15:23
  • Just have done it. – Renan41 Oct 24 at 15:33
  • 1
    When Tramp hangs, you might be able to interrupt it by several C-g. Does this work? You will see then a buffer starting with *debug tramp/ – Michael Albinus Oct 24 at 19:14
1

Just do it as brother up there said, we are having similar problem here and CRTL + g works swiftly, then just check debug buffer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.